Authentication Problems

Celso Kopp Webber celsinho at
Thu Nov 27 19:12:45 GMT 1997

    Hi Patrick.

    I don't know why you can log in at the first time, but this happened the
same way to me, on a very similar configuration as yours.

    I simply solved the problem putting encrypt passwords = yes on my
smb.conf, since the RedHat distributions includes a version of Samba with
LibDES compiled in.
Reading ENCYPTION.txt, I noticed that I would have had to create a smbpasswd
file. I didn't create it and all worked well???

    Is the smbpasswd file really necessary? Can samba work with encrypted
passwords and no smbpasswd file.


    Celso Webber.

Patrick Bauer escreveu:

> hi... i've got Samba 1.9.17p4 running on a RedHat 4.2 Linux box... with a
> 2.0.32 kernel... with pam-0.57-4... and pwdb-0.54-4 installed... what
> happens when i start samba... is that on an NT machine... i am able to
> connect to a Samba network drive the first time... giving username and
> password... but if i open network neighbourhood... and browse the linux
> box which has Samba on it... log out... and then log back in... i am
> unable to connect to that Samba drive again... i guess it is an
> authentication problem...
> /etc/pam.d/samba looks like this...
> #%PAM-1.0
> auth       required     /lib/security/ shadow nullok
> account    required     /lib/security/
> which is fine... and the major options i have enabled in smb.conf are...
>    security = user
> and that's about it... the domain controller stuff and everything that
> relates to that is commented out... also i have the registry updated to
> enable plain text passwords...
> the error message i get when i try to browse again is...
> incorrect password / unknown username for //samba-server
> i have to restart samba... in order to make everything work again
> Pat.

More information about the samba mailing list