Disk unmount - samba fails?

marchino at tin.it marchino at tin.it
Thu Nov 27 20:52:59 GMT 1997

I'm using a Linux box which is serving several Windows 95 PC's as 
file and volume sharing with Samba 1.9.17p4.
One of the disks that are mounted on the linux box is a Fujitsu 2513 
MO-drive. To allow users to be able to change disks in the drive 
without logging to the server, I've used the root preexec, postexec 
and the dead time options as below:

dead time = 3

        guest ok=no
        read only=no
        root preexec=mount -t vfat /dev/sda /mo
        root postexec= umount /mo

This seems to work, and every PC sharing the drive is able to read 
and write to it; but, when trying to copy several files which are 
quite big (about 2-5Mb each) Windows starts to do copying but after a 
while it stops with the message "Windows cannot copy file <fff>: 
volume is no more available" or something like that.
After this error, by running smbstatus on the linux box, I found that 
the MO drive is not mounted but the file being copied just before the 
error message is still open (and locked) by Samba.

I have tried to add "sync always = yes" to the [MO] section but 
without success. I've also try to increase the dead 
time option, but the problem doesn't change. I don't want to remove 
the dead time because after that it would impossible to swap 
cartridges without logging to the linux box - I don't like this very 

I tried to copy the same files to the linux hard disk and then move 
them manually to the MO drive - this works fine, so I think Linux
and the MO drive itself are working well.

Any ideas?



More information about the samba mailing list