SUMMARY: NT w/ SVP3 can not log in to a SAMBA share

Dave dburwell at
Tue Nov 18 17:42:00 GMT 1997

Original problem:
  An NT workstation had Service Pack 3 install, and started getting denied
when they tried to access a SAMBA share that was set for share level security.
  The error message basicly stated that the user was not allow to access
this share from this workstation.
 As I stated in the original message, nothing had changed on the server,
and this NT machine had all proper access before the addition of SVP3. So
there was no reason to look at the SAMBA server to make changes.

  I guess the SVP3 enables encryped passwords by default. The trick is to
go back to using plain text passwords. The DWORD that controls this is
missing from the registry, you have to add it. When you add this value, it
works the way it used to.


  So...Using the regedit program:
  On my system, this value was not present, and an <Edit> <find...>
produced nothing. 
  So, I went to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rdr\Parameters in the
registry, and did an <Edit>, <New --> >, <DWORD Value>
"EnablePlainTextPassword" with a value of 1. Exit regedit and reboot the
  The next time I tried to access the SAMBA share, it asked for my username
and password, and let me in without problems. Just like it used to.

  To those that replied, thanks.
  Thanks to Dieter R. who had the correct answer.

More information about the samba mailing list