smbd can not be started ?

Hongwei Li hongwei at
Thu Nov 13 14:54:11 GMT 1997

Hi Fred,

Thank you very much for your help. I tried, but still failed.  I ran
	/usr/local/samba/bin/smbd -D -s
and got a message 
	option requires an argument -- s
	-s services file

What's that file?  I tried
	/usr/local/samba/bin/smbd -D -s /usr/local/samba/lib/smb.conf
then, no complain, but still nothing happened as before.  What services
file do you use?  Do you also usr -D option (I tried both, with and
without it)?  Any suggestion?


Fred Pishotta wrote:
> I had this problem which stumped me for a while, with p4 and Solaris
> 2.5&6.  The additional symptom was that there was never anything in the
> log files either.  On a hunch, I tried starting smbd with the -s
> switch, and it worked, even though it "should" have worked without
> that, or so I thought.
> I traced the problem to the fact that although the runtime directory
> structure used symbolic links to look the same as the compile-time
> directory structure, they were actually physically different, and the
> "default" path to the configuration files, generated at compile-time was
> the physical path, not the symbolic path.  Hence specifying the path
> to the config files with the -s switch, seemed to fix the problem.
> It's interesting that this was not a problem for nmbd, only smbd.
> Curious.
> -- Fred P.
> On Thu, 13 Nov 1997, Hongwei Li wrote:
> > Hi,
> >
> > I just installed samba-1.9.17p4 on my Linux 2.0.30 system.  It seems
> > okay in compiling and installing.  I run testparm, and it lists the
> > services I set in smb.conf without error message. However, I can only
> > start nmbd, but not smbd -- nothing happens!  So, I can not test it
> > further.  Can anybody give me an idea why it is like that?
> >
> > Thanks for all the help!
> >
> > Hongwei
> >

More information about the samba mailing list