Mode-setting on new directories

Steinar Kaaro Steinar.Kaaro at
Mon Nov 3 09:24:37 GMT 1997

Hello everyone,
I have a problem regarding the mode-setting on new directories.
What I want to do is to set the mode 2775 on new directories.
I have tried all the settings regarding mode, but with no luck.
New files get 2775 (which I don't need), but new directories
only get 0775. Am I missing something here? One strange thing
is that when I run testparm, it is added a zero in front of the
mode-setting? The system I'm running is RedHat 4.1 and the
1.9.17p2 binaries.

Settings in smb.conf:
  comment = WWW-sider
  path = /disk1/httpd
  public = no
  writable = yes
  printable = no
  create mode = 2775
  directory mode = 2775
  force create mode = 2775
  force directory mode = 2775

What testparm says:
Service parameters [www]:
        comment: WWW-sider
        path: /disk1/httpd
        read only: No
        create mask: 02775
        force create mode: 02775
        directory mask: 02775
        force directory mode: 02775

Steinar Kaarø
E-mail: steinar.kaaro at

More information about the samba mailing list