Failure to run programs from a Samba drive

Wroblewski, David A. DavidW at
Fri Dec 12 16:26:19 GMT 1997

I having trouble using Samba.  Everything is fine with respect to file
access.  However, when running programs on NT from a Samba drive, they
fail to run properly run.

For example, when running perl I get the following:

% perl
Could not load ADVAPI32.dll

Other programs fail without explanantion.  If I run the same commands
from a non-samba drive, the commands succeed.  I have tried various
permutations of parameters involving case without success.

Again, file access seems to work as expected. 

I am running Samba version 1.9.16p11 on HP-UX 10.01.

Other problems of lower importance are as follows:

When double-clicking files from the explorer, the files report an error.
 Loading from within the app or using the send to option work.

When logging in to NT and automounting a samba drive, file access fails
when attempting to access files.  If I unmount and remount, everything
is ok.  This has been the case after using wins support = no and
identifying the wins server on our network.  For users with the same
account names on both unix and nt this problem exists.  If a user a
distinct account names, no problem exists.

David Wroblewski
Nations Bank
100 N Tryon St, NC1-007-09-08
Charlotte, NC 28255

Work-Phone: 704-388-2899
Internet: d.wroblewski at

More information about the samba mailing list