Remote printer access

Kitty Weaver kweaver at
Mon Dec 8 18:25:22 GMT 1997

We are trying to add remote PC access to a printer using Samba and the Network 
Neighborhood. We are running Solaris 2.5.1 on our server and our PCs are running 
Win95. We have installed Samba 1.9.16p2. I'm fairly new at administering Samba.

The printer is a high-quality color Tektronics Phasor 450 PostScript printer 
named hq_color_fl2. Access to our other printers has been set up previously 
using [printers] and a local printcap file. 

I'm currently trying to add the entry to smb.conf for this printer.

1) Added it to the local printcap file referenced in smb.conf, but it was not 
recognized. I found a note in the Samba FAQ about printcap names longer than 8 
characters not being recognized. All other printers have names 8 char or less.

2) I then tried adding it as a separate entry in the smb.conf file, following 
the [printers] section:

   comment = All Printers 
   browseable = no
   path = /tmp
   printable = yes
   public = no   
   writable = no
   create mode = 0700

   comment = "High Quality Color Printer at HAO/FL-2"
   browseable = no
   path = /tmp
   printer = hq_color_fl2
   printable = yes
   public = no			<--(unsuccesful, modified to "yes" but   
   writable = no   		waiting to restart the server)
   create mode = 0700

I still do not see it listed when I run smbclient:
Server=[jabba] User=[root] Workgroup=[HAO] Domain=[HAO]

        Sharename      Type      Comment
        ---------      ----      -------
        Budget & Plan  Disk      "/home/admingrp/b_and_p"
        Director       Disk      "/home/admingrp/director"
        haocolor       Printer   
        haoe           Printer   
        haoip          Printer   
        haon           Printer   
        haon_dup       Printer   
        haos           Printer   
        haos_dup       Printer   
        haow           Printer   
        IG project     Disk      "/home/ig_proj"
        IPC$           IPC       IPC Service (Samba Server)
        phasord        Disk      "phasor:/local/d"
        phasord1       Disk      "phasor:/local/d1"
        plotter        Printer   
        root           Disk      Home Directories

NOTE: There were share names longer than 8 chars.
On older clients these may not be accessible or may give browsing errors

Once it is recognized, we plan to install the drivers for hq_color_fl2 on each 

Any advice will be welcome.


--Kitty Weaver			System Administrator - CSMT
kweaver at		NCAR - High Altitude Observatory	
tel: (303)497-1556		P.O. Box 3000
fax: (303)497-1589		Boulder, CO 80307-3000

More information about the samba mailing list