ongoing problem with 2.0.3

john marchant jmarchant at
Mon Dec 10 14:10:14 GMT 2001

I have had a problem I could never fix on 2.0.3 on an alpha.  The nmbd runs
fine, but as soon as a connection is made smbd dies, or rather never starts.
I have made sure it is enabled in the tcpip services (port 139 I think).  I
have started smbd manually with smbd "-D", but upon the first connection it
will die.  If I start smbd again (immediately) and then use explorer, etc.
again. to get to the shares on the alpha, then smbd will continue to
run...Any help?  Is the 1.x.x version better in this area?  Thank you in


if I run SMBD "-D" and then use Windows Explorer the server will accept the
connection and show the shares, but will immediately die and not start
again.  I did it this way, because SMBD would never start manually.  I read
this is how it is different from Unix versions, but it would never start by
itself.  Thus, the manual start.

If I run SMBD "-D" again, and try it, SMBD will continue to work and not
shutdown.  Of course, I only used it this way when I had to manually do some
work on the Windows and OpenVMS machines.  However, now I have to get it
running right permanently.  Any help would be appreciated.

Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (
Version: 6.0.298 / Virus Database: 161 - Release Date: 11/13/01

More information about the samba-vms mailing list