GSoC 2020 Progress Update

hezekiah maina hezekiahmaina3 at
Mon Jul 20 11:54:03 UTC 2020

I did try the workaround given by openSUSE
but it seems I'm having a problem with the directory naming as
the po2json is actually included in the tarball and does not need to be
through npm :
I removed the dependencies and devDependencies in this patch
I will try to rename the directories and will let you know how it goes.

Thank you.

On Mon, Jul 20, 2020 at 1:13 PM Alexander Bokovoy <ab at> wrote:

> On su, 19 heinä 2020, hezekiah maina wrote:
> > Over the past two weeks I have been working on the following:
> > Packaging for Debian and RPM-based distributions
> > Domain Management components
> > Delegation Management components
> > Service Principal Name management
> > UI improvements for the application
> Thank you, Hezekiah.
> I haven't tried to run the plugin yet but the changes look promising.
> I am still on vacation this week, only looked briefly into your OBS
> Fedora build failures. It looks like the failures happen because OBS
> tries to build the app by fetching all node.js from online sources and
> failing to do so, thus not finding required modules (po2json, for
> example).
> When I prebuilt source with 'make srpm' and tried to build that manually
> in COPR[1], it succeeded:
> So we need to find a way to pre-build sources and then build the
> packages. I'll look into that.
> [1]
> --
> / Alexander Bokovoy

More information about the samba-technical mailing list