Regarding "backupuid" option for linux cifs mounts.

Hemanth Thummala hemanth.thummala at
Fri Dec 14 23:30:01 UTC 2018


We are planning to linux SMB mounts for accessing Samba shares for doing metadata scan for backup purpose. We found the mount options like “backupuid” and ”backupgid” which should ideally set the “backup intent” flag in each create request on this mount point. We have tried using the uid(Autorid ID). Mount was successful. However, we are still NOT seeing the “backup intent” flag.

Spent some time looking at the client module source. Looks like it is trying to match the backupuid with the user cred. But, not sure how this cred is supplied. Our client is not part of the domain. Not sure if this step is mandatory.

Here are the mount options that we are using:

sudo mount -v -t cifs \\\\<IP>\\sh1 -o username=bkp_user,password=******,,vers=3.0,backupuid=<autorid-id> /mnt/test

Here is the link that we have followed for documented options:

We are using centos 7.5 with 4.9 kernel version.

Please let us know if you have any suggestions.


More information about the samba-technical mailing list