Minimum python for Samba 4.7

Andrew Bartlett abartlet at
Thu Feb 9 01:15:14 UTC 2017


I've been looking at python both those to disable it and to move us to
python3.  In the python3 patches I'm hitting a conflict with PyCapsule
vs PyCobject, because python 2.7 (which I'm building with) also has

I'm sure it can be worked around, but it got me thinking.  If we have a
maintained '--disable-python', can we then set the minimum python to
build with moved up to Python 2.7?

RHEL 7 has python 2.7, and was released 10 June 2014.  I know many of
our users are still on RHEL 6 or Centos 6, but few of these both want
the AD DC and can't obtain python 2.7 from another repo.  

Other distributions seem to have a modern python, eg OpenSUSE 11 from
2013-05 has 2.7, Debian Wheezy has Python 2.7, precise (12.04LTS) has
Python 2.7.

Therefore, to make the Python 3 migration easier, can we please have
Samba 4.7, due for release 2017-09, require Python 2.7 unless built
with --disable-python?


Andrew Bartlett

Andrew Bartlett
Authentication Developer, Samba Team
Samba Development and Support, Catalyst IT

More information about the samba-technical mailing list