samba 4 rc1: internal dns

Rowland Penny repenny at
Fri Sep 14 08:54:56 MDT 2012

On 14/09/12 15:29, Ricky Nance wrote:
> Aggravating... /etc/resolv.conf
> On Sep 14, 2012 9:27 AM, "Ricky Nance"<ricky.nance at>
> wrote:
>> Phone auto corrected that... /etc/resolve.conf
>> On Sep 14, 2012 9:26 AM, "Ricky Nance"<ricky.nance at>
>> wrote:
>>> For the initial join you just need to make sure that your
>>> /etc/resolved.conf is pointed at your main AD DC. After that samba can be
>>> configured with internal DNS. Look back on the list a few days for more
>>> info on it, documentation is being worked on. Remember if you are using the
>>> git version that you are using 'cutting edge' code, so documentation may
>>> not quite keep up with it :-) .
>>> Ricky
>>> On Sep 14, 2012 9:07 AM, "mpe"<michele at>  wrote:
>>>> Hi all,
>>>> I'm trying to join my rc1 with an existing AD, but there is no how-to
>>>> that I can follow for setup the internal dns.
>>>> If I run the "bin/samba-tool domain join mydomain.local" command,
>>>> samba-tool expect that the mydomain.local are reachable. But since I want
>>>> to use internal dns server, the dns aren't yet working ;)
>>>> So, I do it?
>>>> Another question: where is the documentation for the internal server?
>>>> Where I can find the configuration files, forwarders, etc...?
>>>> Thanks,
>>>> Michele
Hi, if you provisioned RC1 without stating which dns server you want, 
you get the internal one, but there is a couple of gotcha's. It seems to 
set the forwarder to (I believe) what ever is in /etc/resolv.conf (jump 
in here if I am wrong) and the internal dns server DOES NOT LISTEN on . You can fix this by adding the line 'interfaces =' to /usr/local/samba/etc/smb.conf ( where is the 
ipaddress of the AD server). It would seem that all the configuration is 
done in smb.conf.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the samba-technical mailing list