[PATCH][WIP] Make vfs_acl_xattr use hash of the posix ACL

Christian Ambach ambi at samba.org
Wed Oct 31 07:39:34 MDT 2012

On 10/30/2012 09:55 PM, Andrew Bartlett wrote:

> So much for that theory, the remaining talloc_tos() calls are all
> reasonable or at least only on the 'set' side.  Clearly at some layer we
> don't honour the interface promise and allocate the returned NT ACL
> fully on mem_ctx.  The placement of the talloc_stackframe() simply means
> we actually notice the incorrect memory tree.
> However, it's not in the posix_acls or vfs_acl_common code as far as I
> can tell, because valgrind over that code (now quite well exercised by
> samba.tests.posixacl) is clean.
> After setting up things by running enough of make test to run any
> plugin_s4_dc test, I ran:
> SELFTEST_PREFIX=st SMB_CONF_PATH=st/plugin_s4_dc/etc/smb.conf
> PYTHONPATH=bin/python:/data/samba/git/samba/bin/python:/data/samba/git/samba/lib/subunit/python:/data/samba/git/samba/lib/testtools valgrind python -m subunit.run $LISTOPT samba.tests.posixacl
> Christian,
> Given this, can you try and reproduce with and without gpfs, with and
> without vfs_acl_xattr, and with and without NFSv4 ACLs on GPFS, to try
> and help us narrow this down?

As written in my other mail, I ran this on a plain ext3+acl_xattr setup.
valgrinding smbd when accessing a share with vfs_gpfs loaded is not 
possible because of the ioctl() calls that libgpfs does (and valgrind 
does not know about).
So after having seen the issues with vfs_gpfs, I backed out to the basic 
setup and ran valgrind (to see if it passes with the standard code and 
it didn't).

Maybe it's related to my platform or compiler (-flags).

In source3, I used ../packaging/RHEL-CTDB/configure.rpm 


More information about the samba-technical mailing list