winbind crashes..

Collen cblijenberg at
Thu Mar 22 09:18:52 MDT 2012

Hi, not sure but i applied the patch for bug 8807
so my getent group works fine now,

exept getent passwd doesn't, well sort off.

getent only shows 250 (winbind)users, and stops.
if i run getent passwd again, it will show 500 users
after that 750 ect ect

so it gets 250 users per getent query, and caches that (i guess)
i didn't see anny error's in my logs, but i'll investigate more tomorrow

very odd, if you ask me...
did you get more notices of this winbind behavior ?!


> On 22-3-2012 11:53, Volker Lendecke wrote:
>> On Thu, Mar 22, 2012 at 11:17:34AM +0100, Collen wrote:
>>> I'm trying to make samba 3.6.3 work against samba 4 (git pull)
>>> in the past i had encountered some problems with wbinfo
>>> but that is solved.
>>> now a day i can enumerate users/groups with wbinfo again.
>>> it is a migration from s3 (passdb.tdb) with samba-tool.
>>> no errors encountered while upgrading to s4.
>>> the problem i (still) encounter is with getent passwd and group
>>> winbind just crashes with a backtrace on samba 3.6.3
>>> i'm not sure where to debug, on s3 side or s4 side
>>> attached a sniped dump from 363 with db level 50.
>> Can this be bug 8807, i.e. do you have large groups?
>> Thanks,
>> Volker

More information about the samba-technical mailing list