upgradeprovision alpha17 to alpha18: dbcheck errors

Andrew Bartlett abartlet at samba.org
Fri Mar 16 04:29:35 MDT 2012

On Fri, 2012-03-16 at 10:08 +0000, Thomas Mueller wrote:
> hi
> tried to test the upgrade from alpha 17 to alpah18 on debian wheezy/sid.
> i've installed alpah18 on my workstation and rsynced the data from the 
> "live" system.
> before the upgrade i've run "samba-tool dbcheck". it shows 10 errors (5x 
> orphaned backlink attribute 'memberOf', 5x incorrect DN string component 
> for member in object, http://pastebin.com/10gSSzst )
> i proceed without "samba-tool dbcheck --fix".
> I run "/usr/share/samba/setup/upgradeprovision --full" which completes 
> succesfully but one error is printed: "Unable to set ACLs on policies 
> related objects: an integer is required" (http://pastebin.com/Dha2s7C5)
> then i run again the "samba-tool dbcheck". Now it shows 74 errors (many 
> "incorrect GUID component for * in object", http://pastebin.com/s4v34Mng)
> are these messages something to worry about? 

I don't think you should have needed to run upgradeprovision, as we
didn't change the template DB during that time. 


- upgradeprovision should not be run when upgrading to this release
  from a recent release.  No important database format changes have
  been made since alpha16.  

Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba-technical mailing list