[PATCH] Paper over flakey spoolss test

Andrew Bartlett abartlet at samba.org
Tue Mar 13 05:03:04 MDT 2012

As frequent users of autobuild would notice, we have a flakey spoolss
test.  I've tried to find the problem with gdb (and got stuck in to many
signals hitting the process), and tried to find it with valgrind (and
got no valgrind errors).  I've tried with level 10, and level 5 debugs,
and got just hanging processes.  

So, instead here is the paper and glue, to cover over the cracks...

This just makes us fail outright for a printername of "".  I still don't
know why this test ever passes, or why it ever fails, but unless someone
has the time and background to find the real bug, this might help.

Who is maintaining spoolss these days?


Andrew Bartlett
Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-s3-spoolss-Consistently-fail-OpenPrinterEx-with-prin.patch
Type: text/x-patch
Size: 953 bytes
Desc: not available
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20120313/6a6b3522/attachment.bin>

More information about the samba-technical mailing list