How to get DNS replication working properly?

Morten Kramer node1011 at
Sun Jun 24 08:07:27 MDT 2012

On 06/24/2012 02:49 PM, Andrew Bartlett wrote:
> On Sun, 2012-06-24 at 14:43 +0200, Morten Kramer wrote:
>> On 06/24/2012 09:35 AM, Andrew Bartlett wrote:
>>> On Fri, 2012-06-22 at 17:32 +0200, Morten Kramer wrote:
>>>> Hi all,
>>>> I've been trying to get DNS replication to work for a few days now.
>>>> What I've done:
>>>> - Compile Samba (Beta1/Beta2/recent git pull) under Centos 6.2 x64
>>>> Any help will be greatly appreciated!
>>> Could you both please try
>>> git:// fix-dns-replication
>>> If you start with that, for a new join, it should do the replication of
>>> the DNS partitions.  Otherwise, follow the steps you took.
>>> Please let me know if this works, so I can get this in to master to
>>> assist others.
>>> Andrew Bartlett
>> I tried git clone git:// fix-dns-replication
>> But it looks like it's missing the netcmd/ subdirectory and e.g.
>> you patched?
> You need to check out the fix-dns-replication branch, eg
> cd fix-dns-replication
> git checkout abartlet/fix-dns-replication -b fix-dns-replication
> make
> Andrew Bartlett

Checked out the branch, it all compiled fine.

Joined Samba to the Windows 2008R2 domain.

I got a few of those:

Schema update now failed: Invalid DN syntax
Commit failed: Invalid DN syntax
Failed to commit objects: 

After repadmine /kcc, replication succeeded.

I ran samba_upgradedns with SAMBA_INTERNAL as backend.
I started samba again, and then something scary happened:

My win2k8 DC become Unavailable, the Windows DNS server stopped working 
(connection timeout). All the .msc management tools telling me, that 
naming information are unavailable. I'm not sure if the whole DC failed, 
or just DNS?

Since this is productive i quickly had to revert to the snapshot i did 
before the join.

Any ideas?

More information about the samba-technical mailing list