redundant DNS setup with bind_dlz possible ?

Mike Howard mike at
Mon Jun 4 04:01:02 MDT 2012

On 04/06/2012 10:06, Andreas Oster wrote:
>>> Hello Daniele,
>>> did you make some progress with the redundant/secondary DNS setup ?
>>> Does is work for you ?
>>> best regards
>>> Andreas
>> Hi Andreas,
>> I've been trying this for a while now but no matter what I do, or how
>> many times I do it, I cannot get the partitions replicated and so
>> running  samba_upgradedns is futile.
>> I'm spending another day trying but it's wearing a bit thin now :)
>> Cheers,
>> Mike
> Hi Mike,
> I've read that the samba team is planning to release a beta soon. Is
> it not a advisable to first fix the DNS functionality before doing so ?
> I understand, that DNS is a fundamental part of a working AD. What
> benefit would you get from adding additional samba DCs other than some
> load balancing ? If your main DC, hosting bind9, dies the whole AD is
> somewhat useless.
> What do you think ?
> best regards
> Andreas
> you get from
Hi Andreas,

Well, I have to agree. IMHO, an AD environment is pretty much useless 
without the ability to run a fully fledged backup domain controller 
within it.

The Samba team are intending to progress to an internal dns server, 
which makes sense. Not sure if a  working (as in fully capable) DNS 
environment will be included in the first beta, I doubt it from the 
communications on the lists. I personally can't see how it can be called 
'beta' without a (fully fledged) BDC capability but as Andrew has said, 
resources are limited and I guess they want to make progress.

With regards to replication, I tried to start it manually again here a 
few minutes ago but only got errors. as in;

# samba-tool drs replicate ns sheeva 
DC=DomainDnsZones,DC=mydomain,DC=co,DC=uk -UAdministrator
Password for [MYDOMAIN\Administrator]:
ERROR(<class 'samba.drs_utils.drsException'>): DsReplicaSync failed - 
drsException: DsReplicaSync failed (2, 'WERR_BADFILE')
"/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/", line 
331, in run
     drs_utils.sendDsReplicaSync(self.drsuapi, self.drsuapi_handle, 
source_dsa_guid, NC, req_options)
"/usr/local/samba/lib/python2.6/site-packages/samba/", line 
83, in sendDsReplicaSync
     raise drsException("DsReplicaSync failed %s" % estr)

I really can't see any way forward until the relevant part of the code 
is worked on more actively. I'm happy to setup and run any required 
tests but I'm all out of ideas.

Any question is easy if you know the answer!

More information about the samba-technical mailing list