Inconsistent naming of vfs_read in the VFS Function pointer structure ...
idra at samba.org
Sat Nov 26 14:33:01 MST 2011
On Sat, 2011-11-26 at 13:19 -0800, Richard Sharpe wrote:
> Hi folks,
> I came across this:
> /* File operations */
> .open_fn = vfswrap_open,
> .create_file = vfswrap_create_file,
> .close_fn = vfswrap_close,
> .vfs_read = vfswrap_read,
> .pread = vfswrap_pread,
> .write = vfswrap_write,
> .pwrite = vfswrap_pwrite,
> .lseek = vfswrap_lseek,
> Is there any reason that it is vfs_read and not just read?
It may be for the same reason we had to change open -> open_fn, because
glibc at some point made open() into a macro. It is possible the same
happened for read() I guess, on some platform.
Granted, maybe using read_fn would have been more consistent :)
Samba Team GPL Compliance Officer <simo at samba.org>
Principal Software Engineer at Red Hat, Inc. <simo at redhat.com>
More information about the samba-technical