WAF using system versions instead of in tree versions

Sean Dague sdague at linux.vnet.ibm.com
Thu Nov 3 09:54:22 MDT 2011

I ran into some very bizarre breaks in my test tree yesterday, which 
were driving me nuts, until I realized what was going on.

I had run: apt-get build-dep samba4 on Ubuntu 11.10 as a shortcut to 
make sure I had all the right header files to build required bits. This 
brought in packaged versions of libtalloc-dev, libtevent-dev, and 

Even though WAF correctly identified talloc and tevent as too old in the 
configure stage, it still attempted to use them in the link stage.

Also when trying to run "make test", the existence of system level 
python-subunit made the loader for the tests not find them (i.e. "make 
test TEST=samba.tests.X.Y" would fail with a "module does not contain Y" 

Removing this packages meant the build system worked fine again, but 
long term it would be worth making the build work even if other 
libraries were installed on the system.


Sean Dague
IBM Linux Technology Center
email: sldague at us.ibm.com
alt-email: sdague at linux.vnet.ibm.com

More information about the samba-technical mailing list