Samba 4 compiling error

Zahari Zahariev zahari.zahariev at
Thu Nov 18 01:40:14 MST 2010

Hello Hannu,

See that's why you have to provide as many details for what you exactly 
run as possible :)
If you mentioned you didn't use ./configure.developer I would had told 
you that I always use that one and probably most of those who work on 


On 11/18/10 8:58 AM, Hannu Tikka wrote:
> I have tried git clean -x -f -d and also pulling a fresh git repo.
> Those didn't work
> But then I tried different configure commands:
> ./configure and ./configure.nodebug.developer doesn't work
> ./configure.developer works ok
> Hannu
>> On Wed, Nov 17, 2010 at 09:27:10AM -0500, Charles Tryon wrote:
>>> I'm updating and building from the git repository on a semi-regular
>>> basis.
>>>   Something I've noticed is that from time to time, I've had to blow away
>>> my
>>> git repository and pull it again fresh from the server.  It seems like
>>> there
>>> have been times when something changes and it doesn't get properly
>>> cleaned
>>> up.
>>> Of course, this is clumsy if you are actually trying to make source
>>> changes
>>> and log patches, but for me, it's just another script to re-run.
>> Try going to the top level directory and running
>> git clean -x -f -d
>> Always does it for me (and saves pulling again :-).
>> Jeremy.

More information about the samba-technical mailing list