[SOLVED] Samba 4 Success but password change problem

Brian C. Huffman bhuffman at etinternational.com
Tue Nov 16 11:37:33 MST 2010

Min age was biting me.  I had created the account less than 24 hours 
ago.  I set min-pwd-age to 0 and then was able to successfully reset the 


On 11/16/2010 12:44 PM, Matthias Dieter Wallnöfer wrote:
> Hi Brian,
> Brian C. Huffman wrote:
>> First I want to say great work and thanks for such an impressive 
>> piece of work that is samba4.
>> I've got a13 setup and running and have a vista pro VM joined to the 
>> domain.  I've been able to create new users via the MMC plugin and 
>> I'm able to login as that user.  However, when I try to change the 
>> password on the newly created user via Windows, it won't allow me 
>> saying "Unable to update the password.  The value provided for the 
>> new password does not meet length, complexity, or history 
>> requirements of the domain."
> You mean you aren't able to switch on the complexity checks? Then 
> please read the next paragraph.
>> I've tried turning off the default GPO for domain.  I've turned off 
>> complexity.  And I've tried different passwords that should meet all 
>> the requirements, but no luck.
> Probably you still aren't aware of the fact that we don't check for 
> the GPO restrictions yet. In order to modify password settings you 
> have to use the "samba-tool pwsettings" command on the s4 side or 
> manually edit the "pwdProperties" attribute on the domain basedn.
>> On the other hand, changing the password through windows worked fine 
>> for the domain administrator account.
> Greets,
> Matthias

More information about the samba-technical mailing list