s4: renaming lp_ => conf_
abartlet at samba.org
Tue May 18 03:59:35 MDT 2010
On Tue, 2010-05-18 at 11:52 +0200, Stefan (metze) Metzmacher wrote:
> at SambaXP we discussed to rename the lp_* functions in s4 to
> conf_* to avoid symbol conflists with s3.
> If someone starts to do this, please don't use conf_* as prefix,
> I think something like lparm_* or lp_ctx_* would be a better name.
> This will less likely produce conflicts with external headers/libraries.
Isn't C fun :-). I don't like lparm_* or lp_ctx_* but I get your point.
I haven't proposed to do the rename as I'm just not the kind of expert I
would want to be to catch all the cases and not spend all day and night
fixing up the breakage ;-)
Andrew Bartlett http://samba.org/~abartlet/
Authentication Developer, Samba Team http://samba.org
Samba Developer, Cisco Inc.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 190 bytes
Desc: This is a digitally signed message part
More information about the samba-technical