s4: renaming lp_ => conf_

Stefan (metze) Metzmacher metze at samba.org
Tue May 18 03:52:03 MDT 2010


at SambaXP we discussed to rename the lp_* functions in s4 to
conf_* to avoid symbol conflists with s3.

If someone starts to do this, please don't use conf_* as prefix,
I think something like lparm_* or lp_ctx_* would be a better name.
This will less likely produce conflicts with external headers/libraries.


More information about the samba-technical mailing list