[IPA] Attribute Linking and Indexing

Endi Sukma Dewata edewata at redhat.com
Thu Oct 8 22:57:32 MDT 2009


Attached are the patch that I wanted to submit and the test results.
It's supposed to fix some issues including bind credential and
attribute linking configuration.

The problem is there seems to be a memory corruption that I haven't
managed to pinpoint, but I was able to get around it by checking for
a null pointer (see the ldb_msg.c in the patch). The tests result is
also inconsistent from one run to another (see attached files). What
is the strategy for debugging memory corruption?

This patch was created against an older revision from Sep 15:
I used this revision because it's the most stable one that I found
so far.

I tried using the latest revision in master branch but it failed
to compile (implicit declaration of function 'isprint' in torture/

I also tried going back to a revision from Oct 7:
It compiled successfully, but the OpenLDAP test failed even before
I applied my patch on it. It seems that the provisioning tool is
generating some attribute values that are rejected by OpenLDAP.
Is there anybody else testing OpenLDAP using the latest revision?

I haven't got enough information to show you about the new issues,
but how should I proceed from here? Should I continue debugging the
latest revision and submit a single patch that fixes all of these
issues? Or should I look for the newest revision that is stable
enough and create a patch based on it? Or should I fix the issues
separate issues, i.e. leave the attached patch as is and fix the
new issues in a separate patch?


Endi S. Dewata
-------------- next part --------------
A non-text attachment was scrubbed...
Name: quicktest1.summary
Type: application/octet-stream
Size: 961 bytes
Desc: not available
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20091009/9583b927/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: quicktest2.summary
Type: application/octet-stream
Size: 15472 bytes
Desc: not available
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20091009/9583b927/attachment-0001.obj>

More information about the samba-technical mailing list