amba 4 alpha 5 with user_xattr error: system cannot find the file specified

Volker Lendecke Volker.Lendecke at SerNet.DE
Sat Jan 17 11:46:40 GMT 2009

On Fri, Jan 16, 2009 at 09:41:42AM -0500, Ying Hu wrote:
> I am trying samba4 alpha5 because I would like to use the feature of
> xattr for ACL.

The upcoming Samba 3.3 release will also have this feature.
You might want to try the rc releases or even better the
current git branch v3-3-test.

> I set up a PDC. After that, I can join the domain from
> a windows 2003 machine. I can create files fine from the share and I
> can change permissions of the file, which is exactly the feature I
> want to use (I tried samba 3, seems like I can't change permission of
> a file, is that right?).

This is supposed to work even without the xattr acl feature,
although within the limits of what unix permissions and
posix acls allow.

> However, I noticed that I can not drag and
> drop a file from a non-share place to the share and what is worse is
> that, after that action failed, I can't create files from the share
> any more. I always get the error saying system can not find the file
> specified.

If you get the same error with v3-3-test, please post a
debug level 10 log of smbd here or file a bug with


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the samba-technical mailing list