undefined symbol: tdb_setalarm_sigptr

Steve French smfrench at gmail.com
Thu Mar 13 02:37:18 GMT 2008

FYI ran into an interesting problem starting recent Samba.3.2  Did a
git pull then built Samba 3 then did make install into a directory
that had had an older version of Samba in it.  After fixing the lib
path, Samba (/usr/local/samba/sbin/smbd -i) would not start and gave
the following error:

symbol lookup error: /usr/local/samba/sbin/smbd: undefined symbol:

Turned out to be a problem that a symlink to the wrong libtdb had been
automatically created

~/samba-git/samba/source> ls -l /usr/local/samba/lib/libtdb* -l
-rwxr-xr-x 1 root root 55421 2008-03-11 21:51 /usr/local/samba/lib/libtdb.so
lrwxrwxrwx 1 root root    15 2008-03-12 21:09
/usr/local/samba/lib/libtdb.so.0 -> libtdb.so.0.0.1
-rwxr-xr-x 1 root root 58929 2007-09-12 19:11

Fixing the symlink (to point to libtdb.so instead of the older libtdb)
worked (presumably installing Samba into a clean directory - which did
not have an older version of Samba 3 in it would have also worked)

Wanted to post this in case someone else ran into the same thing



More information about the samba-technical mailing list