Inconsistant problem with Alpha5 and group policy

Manu manu.b2007 at
Sat Jul 12 18:48:36 GMT 2008

Hi Wes,

I also experiment "file not found" errors when creating/editing GPOs.
I found a few glitches as well with NT ACLs.

I've been running Samba4 for a few weeks on a new test server, the good
point is that the core application seems very reliable. It's a good file
server for every day usage.


> -----Message d'origine-----
> De : at
> [ at] De
> la part de Wes Deviers
> Envoyé : mercredi 9 juillet 2008 22:01
> À : samba-technical at
> Objet : Inconsistant problem with Alpha5 and group policy
> Alpha 5 cleanly installed and working excellently.  AD join, new user
> creation, profile creation, xattr, everything working great.  Fanstatic
> work!
> But I'm having an intermittent problem with assigning a group policy to an
> OU.
> Setup:
> In the OU, "flamestrike", I have a single user ('carl'), that can log in,
> log
> out, and use the desktop (XP Pro SP2) fine.  I wanted to test the GPO
> stuff
> and we use roaming profiles here, so I thought I'd give it a shot.
> Standard
> setup, no GPO advanced editor or anything.  Right click on the OU ->
> Properties -> GP -> New.  Worked as expected.  Renamed it, worked as
> expected.  Hit "Edit" and got some random error.  I looked around; the
> last
> time I'd checked in the git pull, there was a problem with smbd not
> answering
> for the domain (just the machine) which won't work with the machine tries
> to
> access the GPO via \\domain.
> Checked all the permissions; everything
> in /usr/local/samba/var/locks/sysvol/Policies had good permissions and I
> could get to it.  So I shut down XP, killed & restarted smbd, and booted
> XP
> back up.
> And then it worked!
> So I went into the editor and into folder redirection, set it...and it
> failed.  "Network path not found."  Hit "OK" a few more times out of
> spite,
> they all failed again.  Rebooted, restarted smbd...and it worked again.
> At
> that point, I could set anything in the "User" GPO tree.  Moved to
> the "System" tree to look around and it spazzed again.  "Network path not
> found".  Closed everything, restarted, tried again, and now the GPO
> refuses
> to edit.
> Luckily I captured the entire thing in Wireshark!  Of course, it's huge.
> If
> I'm going to send the error report (this has been a consistant problem for
> me
> for at least a few months, so I may be doing something wrong) what level
> of
> debug dump do you want from smbd, and where should I send the tshark &
> debug
> logs to?  (I can make available via http)
> Thanks!  Excellent work, as always.
> Wes

More information about the samba-technical mailing list