alternate data stream bug in Samba 3.2.1

Volker Lendecke Volker.Lendecke at SerNet.DE
Mon Aug 25 09:52:52 GMT 2008

On Mon, Aug 25, 2008 at 02:45:41AM -0700, lipson wrote:
> Hi guys,
>          Recently I tried to figure out how alternate data stream is
> supported in Samba 3.2.1. What I did was setting the "vfs objects =
> streams_xattr" parameter in smb.conf.  And I expected that the file with
> alternate data stream would be stored as a file with user.Dosstream xattr.
> Here comes the problem. 
>         When I dragged a file with alternate data stream from NTFS to
> mapping driver of samba shared directory, it turns out error message "Can't
> find the specified network name any more....".  I tried to spy with FUSE.
> Then I found that finally the copied file would be "UNLINK" after the write
> operation completed. What's wrong with it ?  Is it another bug with Samba
> 3.2.1 ?  
>         I know that an bug of Samba 3.2.0 with error message "network is
> busy" has already been fixed in Samba 3.2.1 package. But what I said here
> seemed like a new problem.  Anyone has a clue? Thanks a lot!

Can you send a network trace and a debug level 10 log of


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the samba-technical mailing list