alternate data stream bug in Samba 3.2.1

lipson kevin.lisong at
Mon Aug 25 09:45:41 GMT 2008

Hi guys,

         Recently I tried to figure out how alternate data stream is
supported in Samba 3.2.1. What I did was setting the "vfs objects =
streams_xattr" parameter in smb.conf.  And I expected that the file with
alternate data stream would be stored as a file with user.Dosstream xattr.
Here comes the problem. 

        When I dragged a file with alternate data stream from NTFS to
mapping driver of samba shared directory, it turns out error message "Can't
find the specified network name any more....".  I tried to spy with FUSE.
Then I found that finally the copied file would be "UNLINK" after the write
operation completed. What's wrong with it ?  Is it another bug with Samba
3.2.1 ?  

        I know that an bug of Samba 3.2.0 with error message "network is
busy" has already been fixed in Samba 3.2.1 package. But what I said here
seemed like a new problem.  Anyone has a clue? Thanks a lot!

Best Regards 

View this message in context:
Sent from the Samba - samba-technical mailing list archive at

More information about the samba-technical mailing list