[Samba] Segfault/panic with Samba 3.0.23d and setuid

Doug Dimick doug at dimick.net
Tue Jan 23 22:52:09 GMT 2007

Thanks for the pointers, still not sure where this is coming from but it
doesn't look like Samba is the cause, just a symptom. If anyone has any
ideas, please let me know.



-----Original Message-----
From: Volker Lendecke [mailto:Volker.Lendecke at SerNet.DE] 
Sent: Tuesday, January 23, 2007 12:46 PM
To: Doug Dimick
Cc: samba-technical at samba.org
Subject: Re: [Samba] Segfault/panic with Samba 3.0.23d and setuid

On Tue, Jan 23, 2007 at 12:40:59PM -0800, Doug Dimick wrote:
> Interesting... I attempted to "su - nobody" and got the same message.
> Creating another user and asking Samba to use it instead of nobody 
> works initially, but then starts failing with the same error. I 
> definitely have not purposefully modified ulimit or attempted to restrict
system resources.

But you should solve the "su - nobody" first, but this at least seems not to
be a pure Samba problem :-)

The ulimit looks sane, maybe someone else on this list has an idea where
this might come from? I don't right now.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 4105 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba-technical/attachments/20070123/dc54c6a8/smime.bin

More information about the samba-technical mailing list