Group priority problems

jooonte jonas.sheiakh at
Thu Jan 11 13:04:26 GMT 2007


I would like some help with this issue, i will draw up a smallcale scenario
to spare you from the dozends of folders
i have this problem on. Anyways here goes.

Directory structure


on DFS,Documents,BranchOffice i have "administrator" as user and "domain
users" as group with mask 770.
on Staff and Economy i want the two different groups


wich i have masked with "chmod 770 <branch>" and "chmod g+s <branch>" to get
Anyways, i now add the user "test" and add group "staff-users" and
"economy-users" in that order.

and on my fileserver wich runs samba i get this output

groups test
test : domain users staff-users economy-users

I now mount my network driver \\server\dfs to some drive letter and try to
access theese folders.
I have no problem accessing the Staff folder with "staff-users" permissions
but i cant access the Economy folder.

I know remove thoose groups from "test" user and start adding economy-users
and then staff-users to his group-list

and when i run "groups test"
i get this output: "test : domain users economy-users staff-users"

And i now remount the network drive and try to access the folders again, and
now i can access the economy folder but not the Staff folder

I cant get why i have this problem as the Linux see´s both grps but only
lets me access the first listed grp after "domain users" is there some
priority order i need 2 obey.

I run , Debian 3.1 kernel: 2.6.8-2-686
and Samba Version 3.0.14a-Debian

Pls i really need help with this issue, im pretty sure samba cant be limited
to this problem, and its prolly not a very big one.

Some wise person please enlighten me ;)

Kind regards, Jonas

View this message in context:
Sent from the Samba - samba-technical mailing list archive at

More information about the samba-technical mailing list