winbindd panic daemon dies

Andrew Bartlett abartlet at
Fri Feb 6 20:56:55 GMT 2004

On Sat, 2004-02-07 at 03:05, ww m-pubsyssamba wrote:
> Hi Andrew,
> 	more problems I'm afraid. First problem I had was trying 
> to get the use custom configure options, so I dumped 
> that idea and just did a configure/make/make install type installation
>  instead. Still no joy though, I've included my latest out put from 
> valgrind, but it doesn't seem to contain the information you want.

Now it makes sense - the RPM build process strips the debugging

>  I'm running configure as follows:
> ./configure --enable-debug=yes --enable-developer=yes --with-krb5=/usr/local --with-ads --with-winbind
> My Makefile sets the CFLAGS as follows,
> CFLAGS= -g -gstabs -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -DDEBUG_PASSWORD -DDEVELOPER -I/usr/local/include
> A Can you confirm this still isn't providing what you want? 
> Any further requests on how I run any of these steps?

I think it's easy now - just ensure you run
/usr/local/samba/sbin/winbindd manually - you are probably still running
the RPM-built version.

(You will need to copy your smb.conf to /usr/local/samba/lib, and either
set the other paths, redo the domain join, or copy some of the tdbs into
the right places.  


/usr/local/samba/lib to /etc/samba/lib
/usr/local/samba/private to /etc/samba/priviate

Would be the other way to start.

If you can get on IRC, then #samba-technical on might
be a good place to work on this.

Andrew Bartlett

Andrew Bartlett                                 abartlet at
Manager, Authentication Subsystems, Samba Team  abartlet at
Student Network Administrator, Hawker College   abartlet at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url :

More information about the samba-technical mailing list