new talloc stuff

tridge at tridge at
Mon Aug 23 19:48:41 GMT 2004


 > while reading through your new stuff I found it very confusing to have lines like this
 > fnum = create_complex_file(cli, cli, fname);
 > if (!resolve_name(name, name, &ip, name_type)) {

yes, I know it looks odd, but it is correct.

One thing we could do is have this:

 fnum = create_complex_file(cli, (TALLOC_CTX *)cli, fname);

the cast is pointless from a C perspective, but might make the code
easier to read.

Cheers, Tridge

More information about the samba-technical mailing list