KIP, Powerprint Request software -samba

mnehemiah at mnehemiah at
Wed Aug 11 19:23:57 GMT 2004

Hi David,
              I have seen the explorer feature, that opens files looking
for icons and slows down your directory listing.  It could
be something similar, but I dont know.  The powerprint
software directory listing is 4 colomns, 1-checkbox for
selection, 2- filename, 3- size, 4 mod date.  That is it, no
icons, and no options to change the directory listing view
at all.   Thanks, for the response.   Any other ideas for me
to try?


---------------------------- Original Message ----------------------------
Subject: Re: KIP, Powerprint Request software -samba
From:    "David Collier-Brown" <davec-b at>
Date:    Wed, August 11, 2004 11:29 am
To:      mnehemiah at
Cc:      samba-technical at

>    This looks somewhat familiar: Windows Explorer has a tenancy
> to try to open all files in a directory in order to show a pretty
> screen of icons, each read from icon information in the file.
> Powerprint may well be doing something similar.
>    When starting up the powerprint file browser, does it by any
> chance have an option to just list filenames, or use small
> icons, or something that causes it to not to try to open all
> the files?  If so, try it and see if it causes a huge speed-up.
>    If not, we might have to pull some sort of kludge, such as
> a vfs that returns precached icons without actually opening the
> files.  It's the directory traversal (namei/iget) and file opens
> that take the time on Unix.
> mnehemiah at wrote:
>> Hi all,
>>         Before  I get started on my troubles now, I want to thank the
>> team
>> for everything they've done, and helping me before with my clarion
>> database locking issues.  We have been running all of our production
>> clarion databases on samba since then, with no known issues.  Hats off
>> to
>> the team and all who contribute.
>> Description: Engineering dept uses wide format Kip brand printers,  They
>> use proprietary kip software for maintenance on large numbers of image
>> files on the server. Before samba, the files were on $NT4(&nt4 era
>> hardware).  In their software, opening a typical directory(4000 files)
>> took a long time ~15s.  Now, on samba they get 2min10seconds directory
>> open time.    I set up a test network to troubleshoot.  My test network,
>> I
>> can get the directory time down to 38secs. on samba 3.0.5  Several
>> engineers use this program daily for file moving, manipulation, etc.
>> and
>> it is just unbearable to use.   I tried an xp share, and the time was
>> 8secs.  I have been in contact with KipAmerica on this issue, and they
>> are
>> not interested in helping.  I hope one of you guys can look at this for
>> me, it seems easy to recreate, and I think there is a definite problem
>> somewhere here.
>> To Re-create:
>> I originally worked with our production files.
>>     For re-creation purposes,  Just use 4000 empty files. It is slightly
>> faster with empty files.  bash: for n in `seq 4000`;do touch $n;done.
>> Download windows software from Kip, Powerprint Request latest version.
>> or direct download -
>> -(free download)  Install software on a windows box.  Have shared folder
>> with files mounted on windows box.
>>     Powerprint request software opens up with a directory/File browse
>> window.  find your folder with the 4000 files, click on it and watch how
>> long it takes to open.
>> I have had this problem since we moved their files.  I have tried 3
>> different server hardware configs, and many tuning parameters from
>> noatime
>> on mounts to several of the TCP options.   latest samba test config is
>> at
>> the end.  I feel confident that this problem can be reproduced easily.
>> Please, let me know if there is any more information I can get to you on
>> this, or if there is anything I can do to help diagnose.  I'm stuck
>> right
>> now, in a real bad way with our Engineering dept.  I really have to come
>> up with an answer on this problem for them.
>> Thanks,
>>                  Mark..
>> all disks were formated ext3, used single ide drives, and 3ware raid 5s,
>> smb.conf
>> ***
>> [global]
>>    workgroup = AAAAAAA
>>   netbios name = Nemo
>>    server string = Nemo's Kip test thing
>>    log file = /var/log/samba/log.%m
>>    max log size = 50
>>    security = domain
>>    password server = *
>>  encrypt passwords = yes
>>    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
>>    wins server = 10.x.x.x
>>    dns proxy = no
>> [homes]
>>    comment = Home Directories
>>    browseable = no
>>    writable = yes
>> [printers]
>>    comment = All Printers
>>    path = /var/spool/samba
>>    browseable = no
>>    guest ok = yes
>>    writable = no
>>    printable = yes
>>    create mode = 0700
>>    print command = lpr -P %p -o raw %s -r   # using client side printer
>> drivers.
>> [print$]
>>    path = /var/lib/samba/printers
>>    browseable = yes
>>    read only = yes
>>    write list = @adm root
>> [Kip_files]
>> path=/server
>> writable=yes
>> *************

More information about the samba-technical mailing list