KIP, Powerprint Request software -samba

mnehemiah at mnehemiah at
Wed Aug 11 15:46:12 GMT 2004

Hi all,
        Before  I get started on my troubles now, I want to thank the team
for everything they've done, and helping me before with my clarion
database locking issues.  We have been running all of our production
clarion databases on samba since then, with no known issues.  Hats off to
the team and all who contribute.

Description: Engineering dept uses wide format Kip brand printers,  They
use proprietary kip software for maintenance on large numbers of image
files on the server. Before samba, the files were on $NT4(&nt4 era
hardware).  In their software, opening a typical directory(4000 files)
took a long time ~15s.  Now, on samba they get 2min10seconds directory
open time.    I set up a test network to troubleshoot.  My test network, I
can get the directory time down to 38secs. on samba 3.0.5  Several
engineers use this program daily for file moving, manipulation, etc.  and
it is just unbearable to use.   I tried an xp share, and the time was
8secs.  I have been in contact with KipAmerica on this issue, and they are
not interested in helping.  I hope one of you guys can look at this for
me, it seems easy to recreate, and I think there is a definite problem
somewhere here.

To Re-create:
I originally worked with our production files.
    For re-creation purposes,  Just use 4000 empty files. It is slightly
faster with empty files.  bash: for n in `seq 4000`;do touch $n;done.
Download windows software from Kip, Powerprint Request latest version.
or direct download -
-(free download)  Install software on a windows box.  Have shared folder
with files mounted on windows box.
    Powerprint request software opens up with a directory/File browse
window.  find your folder with the 4000 files, click on it and watch how
long it takes
to open.

I have had this problem since we moved their files.  I have tried 3
different server hardware configs, and many tuning parameters from noatime
on mounts to several of the TCP options.   latest samba test config is at
the end.  I feel confident that this problem can be reproduced easily.
Please, let me know if there is any more information I can get to you on
this, or if there is anything I can do to help diagnose.  I'm stuck right
now, in a real bad way with our Engineering dept.  I really have to come
up with an answer on this problem for them.


all disks were formated ext3, used single ide drives, and 3ware raid 5s,

   workgroup = AAAAAAA
  netbios name = Nemo
   server string = Nemo's Kip test thing
   log file = /var/log/samba/log.%m
   max log size = 50
   security = domain
   password server = *
 encrypt passwords = yes
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   wins server = 10.x.x.x
   dns proxy = no
   comment = Home Directories
   browseable = no
   writable = yes
   comment = All Printers
   path = /var/spool/samba
   browseable = no
   guest ok = yes
   writable = no
   printable = yes
   create mode = 0700
   print command = lpr -P %p -o raw %s -r   # using client side printer

   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   write list = @adm root


More information about the samba-technical mailing list