REPOST: Problems with Mac files?

David Collier-Brown davec-b at
Sun Aug 8 18:28:41 GMT 2004

Ashley M. Kirchner wrote:
>    Does anyone have an answer to my post a few days ago?  Here's the 
> archived post:

>    I have a Win2K Server that acts as a file server to a bunch of 
Macintosh machines on the network.  Today I installed samba-3.0.5 on a
Fedora1 machine, and mounted one of the server shares and tried to read
it.  Much to my surprise, I found files that are being listed like this:

-rwxr-xr-x  1 root root      0 May 13 16:30 Icon?*
-rwxr-xr-x  1 root root  25649 Aug 23  2000 webslide151.gif*
-rwxr-xr-x  1 root root  57619 Mar 26 08:22 ???webslide1581.JPG*
-rwxr-xr-x  1 root root  26132 Mar 26 08:22 webslide1631.JPG*
-rwxr-xr-x  1 root root  67711 Aug 18  1999 webslide176.gif*
-rwxr-xr-x  1 root root  70559 Mar 26 08:22 webslide1771.JPG*
-rwxr-xr-x  1 root root  80792 Mar 26 08:23 ???webslide1851.JPG*

	Ok, I read this as saying you used the smb mount program
	on Linux to mount the files, and they looked weird.
	1) I **think** this is the translation on Linux of characters
	   that Macs put in filenames. It looks like the Mac
	   created an Icon file which ended in a special character,
	   which got displayed as a ?
	2) Why the files are all executable I don't know: this
	   could be a Mac-ism or the setting of the file to "hidden".
	   The latter implies that all the files shown here are
	Check the path used in the smbmount command: you need to know
	if it's the path to the new Samba 3.0.5 command or the one
	which came with your Linux.


    When looking at the files on the Win2K serer, they're fine - they can
be opened with no problems or anything.  There are no extra characters
on those file names, and yet samba displays them with ??? in the front.
The "Icon?" is the folder icon resource that any Mac machine 
creates in
any folder they dive in to.

    If I try to run a 'du' on the mount, I get errors like this:

$ du -h --max-depth=1
31G     ./ INKJET
132M    ./Font Library
du: cannot access `./ICON?': No such file or directory
680M    ./Jon S Folder
8.0K    ./Network Trash Folder
8.0K    ./RECYCLER

	Du knows a lot about the format of unix filesystems, and may be 	
	be getting befuddled by being used on a mounted smb file

    If I run rsync on the mount (which is ultimately what's going to
happen,) the first run gives me errors on the three "weird" files
(Icon?, and the two that start with ???) and a second run will copy them
over, as if nothing happened.

	And I can't even guess at this, I don't know enough about rsync.


More information about the samba-technical mailing list