trouble with printer driver upload on win XP sp1

Stefan (metze) Metzmacher metze at
Fri Jul 18 18:40:09 GMT 2003

At 20:31 18.07.2003 +0200, Stefan (metze) Metzmacher wrote:
>Hi Jerry,
>I have problems with uploading printer drivers from my win xp sp1 boxes...
>(HP DeskJet 850C printer, but I tried others with the same effect too)
>- The driver files are copied to the server fine, but the files should go to
>   \\Smb-1\print$\W32X86\3\
>   but they're going to
>   \\Smb-1\print$\W32X86\
>   instead
>   Then the files are removed and I got an error
>   "Could not install driver for win 2000 amd win XP" (I got a german 
> error message...)
>   If I install the driver locally to the winx xp box all worked fine...
>   the drivers go to
>   C:\WINDOWS\system32\spool\drivers\w32x86\3\
>   I noticed that the registry pathes are a bit different between XP sp1 
> and samba.
>   What do you need?
>   I can give you:
>   - samba logs
>   - ethereal trace
>   - the [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\... stuff
>   The win NT 4 /win 200 driver is installed on the server fine...
>   So everybody who is NOT an admin can print fine with over the old 
> driver on XP.
>   But when I try to print as admin.
>   I can press the print buttom and the job goes out (or not?)...
>   I got no error message!
>   But at the printer (I'm using CUPS) nothing is happen.
>   And the cups logs didn't show the print job :-(

[2003/07/18 20:38:53, 0, pid=23675] printing/print_cups.c:cups_job_submit(756)
   Unable to print file to PRT02 - client-error-document-format-not-supported

This happen in that case

Stefan "metze" Metzmacher <metze at> 

More information about the samba-technical mailing list