Samba 3.0 CVS: configure problem

Green, Paul Paul.Green at
Wed Feb 26 16:05:03 GMT 2003

It can't find  The test is bad because this should not have
aborted configure. The clues are these lines:

configure:20621: checking for test routines
configure:20637: gcc -o conftest -O   -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64  conftest.c -lsec -lgen -lresolv -lsocket -lnsl -ldl
-liconv >&5
configure:20640: $? = 0
configure:20642: ./conftest ./conftest: fatal: open failed: No such file or
./configure: line 1: 28954 Killed                  ./conftest$ac_exeext
configure:20645: $? = 137
configure: program exited with status 137
configure: failed program was:
configure:20655: error: cant find test code. Aborting config

and now it dies.

Paul Green, Senior Technical Consultant, Stratus Technologies.
Day: +1 978-461-7557; FAX: +1 978-461-3610
Speaking from Stratus not for Stratus

-----Original Message-----
From: Joe Meslovich [mailto:joe at]
Sent: Wednesday, February 26, 2003 10:30 AM
To: samba-technical at
Subject: Samba 3.0 CVS: configure problem

I got the latest CVS copy of samba 3.0 today. I ran to create
configure. And then I configured the system --with-quotas
--with-acl-support. The configure script bombs when it gets to the part
about test routines. It ends with:

error: cant find test code. Aborting config

 I am including a gzipped copy of my config.log. The system is Solaris 9
x86. I installed the recommended GNU libiconv-1.8 in /usr/local yesterday.
I tried configuring a CVS copy of Samba 3.0 from the 19th of February
--with-libiconv=/usr/local. That configure failed in the same way, but
configureing with only --with-quotas and --with-acl-support worked. I then
tried the same with a copy from today the 26th. I cannot get configure to
finish properly at all. I am not certain if the error is related to
libiconv. That is why I included the log.

Joe Meslovich						joe at
Associate Network/Systems Engineer	                IT Center
Tel: (540) 828 - 5343

More information about the samba-technical mailing list