[odd behaviour] printing = cups && printable = yes

Fabien Chevalier fabien.chevalier at supelec.fr
Sat Dec 6 21:41:14 GMT 2003

Hi all,

This post follows Joerg Pulz post on samba list (2003-11-12) on the same subject

I'm currently playing with cups & Samba 3.0.1pre3, and came with the need to support
a hole bunch of 'classical' cups printers :-), as well as some custom print queues
with home cooked processing...but it seems it currently isn't supported :-(

As noticed by Kurt Pfeifle, Example 19.2. of HOWTO Collection,  "Overriding global CUPS settings for one printer"
(which is exactly what i would like to have) doesn't work anymore with today's Samba 3.

Here is how it works today :  as soon as you choose printing = cups, whatever
share is marked with printable = yes got redirected to CUPS API, which complains
that it doesn't know how to handle this print queue ...of course!!

For my side i tried to do cups printing with printing = sysv, but i feel this is some kind
of a weird approach...and it's really hard to debug (read: it still doesn't work after
a half day work ;-)

Would anybody have a workaround to make this kind of setup work again?
Or better a long term solution?

Best Regards,

Fabien Chevalier

More information about the samba-technical mailing list