Netbench and Samba 2.2.1a

Herb Lewis herb at
Thu Jun 13 10:03:07 GMT 2002

I run in user security and use altiris software to send remote
commands to the clients. I ran into this same problem but was
able to solve it by having the remote command to the client be
a batch file that mounted the share and then invoked the netbench
client program. That way the share mount and the client program 
are running in the same security context.

Don DeVitt wrote:
> I am the colleague David reefers to below. I haven't had time
> to update Dave on what I learned about this problem.
> There is NO problem with Samba.
> My problem was caused by the fact that NT mapped drives are not
> accessible in exactly the same way by an application launched by
> a Remote Shell Daemon as they are from applications that
> are launched by the user from the desktop. The authentication is
> some how different enough to make the drive inaccessible without
> using the "security = share" smb.conf file setting.
> This problem is documented by NT version of the rshd software
> ( I initially missed it because
> I usually use the W98 version of the RSHD software where the problem
> does not occur.
> There are other ways around the problem, but the "security = share"
> smb.conf file setting works is working fine for now.
>  Don DeVitt

Herb Lewis                               Silicon Graphics 
Networking Engineer                      1600 Amphitheatre Pkwy MS-510
Strategic Software Organization          Mountain View, CA  94043-1351
herb at                             Tel: 650-933-2177                       Fax: 650-932-2177          

More information about the samba-technical mailing list