Very bad performance when copying large files from windows to samba-share

MCCALL,DON (HP-USA,ex1) don_mccall at
Fri Apr 12 13:00:03 GMT 2002

The fact that you have disk activity with no network activity
on the samba server when you try to transfer, and the timeout
issue, almost sounds like you have the 'strict allocate' flag
for smb.conf set true - this would force samba to actually write
bogus data to fill up a file on your disk of the size that you are
about to transfer, and if it were really big, or disk writes really
slow, could be causing you to time out... check testparm output for 
'strict allocate' and see what the value is - it SHOULD default to 
no, or false, but maybe your distribution changed the default on you?
Just a guess,

-----Original Message-----
From: Lars Heineken [mailto:Lars.Heineken at]
Sent: Friday, April 12, 2002 9:35 AM
To: samba-technical at
Subject: Very bad performance when copying large files from windows to

Hi !

I'm searching for an answer to this problem for a while, maybe this is the
right place for help ?

I share my drives with samba, (smb.conf is nearly unchanged from default).
Lately my brother tried to move a 780MB file onto one of my shares. As samba
is working fine with all other files, I thought everything would work fine. 

It didn't.

So here's the problem:
No Windows-client can copy files larger than about 700MB onto one of my
shares. The moment the transfer starts, no popup-window appears on the
windows-screen, but my disk begins heavy writing, even no single packet is
floating through the network. After about 30seconds the connection times
out. The copied file can be found on my share but it's empty.
The logs say something about oplocks, but as I turned them off for a test
nothing changed.
When my brother maps the drive and copies the file inside the DOS-box,
everything is fine.
It seems that the win98 explorer has some kind of bug, that tells him to set
up an empty file before he starts writing.

As there must be a way to copy large files from windows to a samba-share,
I'm seeking someone who has solved this problem.


Lars Heineken.

PS: I read the man page about smb.conf and all switches that could have an
effect are set up correctly by default. Running version is 2.2.3a-10mdk.

More information about the samba-technical mailing list