Procedure Number out of Range

Cherik cheriks at
Fri May 25 22:34:10 GMT 2001

Hi again,
Well I have effectively pulled out ALL of my grey hair. My network has been 
down for 2 weeks now and I still can't get past this problem. I d/l'd the 
latest cvs this morning and started from scratch again to no avail. I have 
scoured the web and the boards to find an answer. No luck =(
I have however come to the conclusion that no one really knows what causes 
this error, or even what the error means. Some nice people have replied with 
tips and tricks that have worked for them, but there is no consistency, and 
none have worked for me. There are allot of holes in the various PDC How-Twos 
that just leave allot to the imagination. I guess I am just doing something 
fundamentally wrong.
In a nutshell, I am running a Linux box with Mandrake 8.0 that I am setting 
up as a file server / PDC for various other OS's that include 98, win2k pro 
(some sp1, some not, none sp2), and linux MDK 8.0 clients. Some machines are 
multi-booting. I have the latest cvs running as of today.
I compiled with these options

debug - smbwrapper - automount - smbmount - syslog - profile - pam 

I then configured my smb.conf as follows

# Global parameters
	workgroup = RAW
	netbios name = RMTSERVE
	server string = RAW Samba Server
	interfaces =
	encrypt passwords = Yes
	allow trusted domains = No
	smb passwd file = /usr/local/samba/private/smbpasswd
	passwd program = /usr/bin/passwd %u
	password level = 4
	username level = 4
	debug level = 5
	syslog = 2
	log file = /var/log/samba/log.%m
	max log size = 5000
	debug uid = Yes
	name resolve order = wins lmhosts host bcast
	domain admin group = @root
#	add user script = /usr/sbin/adduser -c 2kmachine -d /dev/null -g 100 -s 
/bin/false %m$
	logon script = scripts\%U.bat
	domain logons = Yes
	os level = 64
	local master = Yes
	security = user
	logon path = \\rmtserve\profiles
	logon home = \\rmtserve\home\%U
	logon drive = h:
	preferred master = Yes
	domain master = Yes
	wins proxy = Yes
	wins support = Yes
	admin users = @rmt
	hosts allow = 192.168.0. localhost
#	printing = cups
#	print command = /usr/bin/lp -d%p -oraw %s; rm %s
#	lpq command = /usr/bin/lpstat -o%p
#	lprm command = /usr/bin/cancel %p-%j
#	queuepause command = /usr/bin/disable %p
#	queueresume command = /usr/bin/enable %p
#	share modes = No

	comment = Home Directory
	path = /home
	writeable = Yes
	guest ok = Yes

	comment = Profile Redirect
	path = /home/%U/profile
	read only = No
	guest ok = No
	browseable = No
	writeable = Yes
	create mask = 0600
	directory mask = 0700

	comment = The Domain Logon Service
	path = /home/netlogon
	writeable = No
	force create mode = 0444
	browseable = No
	write list = ntadmin

	path = /usr/tmp
	guest ok = Yes
	printable = Yes
(Note: I Tried various add user scripts before I commented it out, and made 
them manualy)

I then added all the users to the smbpasswd file, and verified that they had 
the same UID's as the entries in the passwd file.

I then started the daemons, and ran all the troubleshooting tests from Gerald 
Carters Book "Teach Yourself Samba in 24 Hours"

Everything went smooth other than the smbd test where if I try to use the 
command "smbclient -L rmtserve -N" I get a "ERRSERV"  "Invalid Network Name 
in Tree Connect" Without the switch -N it prompts for a p/w, and with the 
root p/w it works.

I then fire up one of my 98 machines under user level security and Whola! I 
can log in as any user and it runs my login script.
Then I try my 2k box with one of the many user add scripts I had in smb.conf 
and I get that ugly error. So I go to add the entries manually. 
root# adduser -g 100 -d /dev/null -c 2kmachine -s /bin/false -m 
root# smbpasswd -a -m machine_netbios_name
Rem out add user script in smb.conf
cat both entries, all ID's look good, both accounts reflect the $ properly, I 
try again. Same thing.
I will try anything at this point, I will send level 10 logs if someone will 
check them out. Please help before my boss says screw it and put NT Server on 

Very Bald and considering alcoholism,
Erik Peirson

More information about the samba-technical mailing list