Locking Database error.

REYNAUD Jean-Samuel reynaud at nantes.inra.fr
Wed May 2 07:13:44 GMT 2001

Le 2001.05.01 02:37:17 +0200, Trevor Benson a écrit :
>    I just built a new Redhat 7.1 server. I installed the RPM package from
> ftp.samba.org <ftp://ftp.samba.org>  and after I run the smbd and nmbd I
> still end up with this error below. I have checked this list, and gone
> through the Project Doc's and the FAQ's, I originally posed on the samba
> group, and had no response there.  I am not part of the technical mailing
> list, so if anyone has a suggestion please make sure to reply.  If you would
> suggest I join this list as well, please mention it, I will do it right
> away.  
>    Nothing seems to reference the locking database not initializing.  Has
> anyone else had this issue?  On a fresh system with the RPM I wouldn't
> expect to have this much trouble, that's why I left the old 6.x server as is
> and tried to move forward with a test box to see if I couldn't resolve this.
> Any help or idea's would be appreciated. The log.smbd and nmbd have NOTHING
> in them at this point. Im not really sure what to do.
> Samba version 2.2.0
> Service      uid      gid      pid     machine
> ----------------------------------------------
> Failed to open byte range locking database
> ERROR: Failed to initialise locking database
> Can't initialise locking module - exiting
> Thanks,
> Trevor Benson
> Director of Information Technology
> Associated Business Products
I don't know if your problem is the same, but :
With smbstatus I have the message

connections.tdb not initialised

The problem come from the localtion of the lock directory:

For smbd it's /var/lock/samba
For other (???) it's /var/locks.

So I make a symlink /var/locks -> /var/lock/samba

And it's working.

REYNAUD Jean-Samuel

More information about the samba-technical mailing list