VxFS quotas

andrew morgan morgan at orst.edu
Tue Mar 27 15:55:32 GMT 2001

On Tue, 27 Mar 2001, David Lee wrote:

> Yes.  We are successfully running a very similar system:
>    samba 2.0.7, Solaris 8, VxFS 3.4
> And until Christmas we were running :
>    samba 2.0.7, Solaris 2.6, VxFS 3.? (prob. 3.2)
> <!-- history attribute="boring" action="skip" -->
> I developed samba's VxFS quota support on an even earlier version of samba
> (2.0.5, I think), and it has continued to work under the various upgrades
> (samba, Solaris, Veritas).
> During term-time, we typically have 700 simultaneous connections on this
> fileserver.  And on the odd occasions when we have had trouble with quotas
> which were on much smaller, but non-Veritas servers, the users have
> certainly let us know...!
> The code was informally checked by someone in Veritas who has an interest
> in samba, and he also submitted a couple of improvements to it before
> release in the samba distribution.  Although the official line from
> Veritas is no support (see the disclaimer in the source), nevertheless the
> Veritas person who checked it was keen to see that it worked OK.
> <!-- /history -->
> So I am reasonably confident that it basically works.  (But I'm also quite
> willing to believe that my code might have a lurking flaw...)
> I wonder...  Although you have set the quota for the user, is the quota
> system actually running on that filesystem?  (Nothing to do with samba.)
> Just as on a Solaris UFS you need the /etc/vfstab "rq" attribute, so with
> Veritas you would need the /etc/vfstab "quota" attribute.
> Your first step should be to forget about samba.  Rather, simply verify
> within Solaris that quotas really are working, by creating and deleting a
> few UNIX files and watching the quota.  Only when you are happy with the
> UNIX (non-samba) behaviour should you then look to the samba behaviour...

Ack!  You are right.  Another kind soul sent me a private email saying the
same thing.  I had quotas enabled for a while, but a system reboot turned
them off again because I had not added 'quota' to the vfstab options

I suppose they had to map that error onto some regular errno, but "no such
process" didn't really clue me in that quotas were disabled.  And all the
quota utilities worked fine...

This server will also be running netatalk for mac users to access their
home directories.  Would it be okay for me to use your code in netatalk?


More information about the samba-technical mailing list