Invalid handle using SAMBA_2_2 from CVS...

Paul Sanders sanders_p at
Tue Mar 13 14:32:04 GMT 2001

G'morn to all:

Is it possible that there was a problem with SAMBA_2_2 CVS yesterday?  I built
two servers from scratch using RHL6.2 and samba 2.2 from cvs [about 9 am EST]. 
I set up printcap and smb.conf [actually ripped from a functioning server and
modified for these boxes...] and all looked well.  Problem occured when
attempting to print from NT or W2K - I recieved an "Invalid Handle" error and
nothing queues.  I forgot to mention that test prints from printtool and Webmin
worked as expected as does injecting a job via smbclient [ echo "blah blah blah"
| smbclient "//server/queue" -U% -c "put - f" ].

I dug up a copy of the samba 2.2 alpha 2 shapshot, compiled and installed it. 
I left everything else the same [printcap, smb.conf, users, etc] and started up
samba.  Test pages worked as did printing from NT/W2K - no invalid handle

Since I made no other changes to the system I am left with samba being the
culprit [of course, I leave open the possibility that the system admin has a
blown buffer...].  Any thoughts?  

Thanks in advance.

Paul Sanders

More information about the samba-technical mailing list