NIS Groups on 2.2

Gerald Carter gcarter at
Tue Jul 3 14:02:51 GMT 2001


Can you reproduce this using the latest SAMBA_2_2 cvs code?

cheers, jeerry

On Tue, 3 Jul 2001, Nick Tan wrote:

> Hi all,
> I've upgraded from Samba 2.0.7 to 2.2.0 on a Solaris 2.7 server
> running as a NIS client.
> I have samba set to security = domain, and joined the NT domain using
> smbpasswd -j.  My aim is for the samba server to pass authentication
> off to the PDC, which seems to be working mostly.
> I have a share defined with valid users = @groupname which worked
> perfectly on 2.0.7.  However with 2.2.0, it would only let the user
> access the share if groupname is their primary group.
> I tried 2.2.0 on a linux 2.4.3 (Redhat 7, also NIS client) machine
> with the same config file (except for servername etc), and it worked
> for all users who are in the group.
> I've added individual usernames in the valid users field for now which
> works but isn't very pretty.
> I've searched through the archives and the website trying to find any
> information on this before posting, but couldn't find anything.  I
> hope I've provided enough information, but please let me know if I
> haven't.
> Thanks for any help,

 ---------------------------------------------------------------------     VA Linux Systems      gcarter at          SAMBA Team             jerry at                           jerry at
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca--

More information about the samba-technical mailing list