Strange Win-client probs while Linux clients work

Carsten Reckord creckord at
Thu Aug 16 17:22:50 GMT 2001

Hi folks,

I am currently experiencing some (at least to me) REALLY weird problems:

Using Samba 2.2.x (tried 2.2.0 and 2.2.1a) I have set up a Samba-Server 
with userlevel security. Accessing the server from a Linux box works 100% 
But same thing on the SAME CLIENTS running either Win2k (SP1) or WinNT(SP6) 
leads to problems - see below, but first the config:

The smb.conf file I use (a minimalistic one for testing purposes) looks as 
follows (including some different values I checked out):

   encrypt passwords = Yes
   os level = 80
   preferred master = Yes/No
   dns proxy = Yes/No
   hosts allow =
   interfaces = # tried w/o too
   browseable = Yes
   map to guest = Bad User
   guest account = nobody
   wins support = Yes/No
   wins proxy = Yes/No
   browseable = No
   hosts allow =

   valid users = root
   hosts allow =

   guest ok = Yes


Ok, now for the problem: 
I can browse the share list from the windows clients without problem, 
mounting the shares is no problem either.
But trying to access the contents of some of the shares I am out of luck.
For example I cannot list the contents of my homedir (e.g. for root) 
mounted through the homes-share or the contents of the full-share. Likewise 
I cannot list the contents of some sub-directories of the docs-share 
(packages, faq/faq ...). Using the Explorer to do so it takes about 1 
minute and then I get something like "cannot access share. network name no 
longer exists" or "network path not found". Typing dir in a dos box just 
returns an empty list after the same 1 minute.
Trying to copy a file to one of those shares/dirs from the Explorer nothing 
happens at all, from the dos box I get a "write error".
tmp-share and some other subdirs of the docs-share work fine.

To make things even stranger: Using the same config with the same samba 
version on a different Linux box (same Distribution/kernel/...) there are 
no problems at all...

Does anybody have any idea about that? Thanx in advance.

In case you need more information:

-Server is SuSE Linux 7.2, Kernel 2.4.4
-Directories I talked about are all owned by root/root and have permissios 
755 (700 for roots home)

Some other stuff running on the server:
ISC dhcpd 3.0rc4
Bind 9

And in case you really want to investigate deeper in this I have added 
gzipped level 3 protocols of a successful connect to the tmp-share and a 
messed up connect to the full-share, both beginning with a freshly started 

So again, thanx in advance for any help...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smb_tmp.log.gz
Type: application/x-gzip
Size: 4770 bytes
Desc: not available
Url :
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smb_full.log.gz
Type: application/x-gzip
Size: 2217 bytes
Desc: not available
Url :

More information about the samba-technical mailing list