Page defaults (Was: 2.2 release imminent.)

Christopher Odenbach odenbach at
Wed Apr 18 11:57:21 GMT 2001


> > Well, as I told you several times before, I still have problems with
> > automatic printer driver download. The download itself works, but the
> > document defaults settings are not working. I can very well set the
> > defaults and they _are_ saved, but they are not _read_ or _taken_ for
> > new documents. When I open "WordPad" and look at the page settings, the
> > page size is "Letter". not "A4" as I set in the defaults.
> > 
> > I tried 2.2.0a3 on both Solaris and linux and get the same results, I tried
> > different NT workstations - same results.
> I need complete details on how to reproduce this. Client 
> types, Samba build info, Samba server OS version, and 
> especially printer driver details. Also a complete idiots
> "click here and do this" step by step of what you are doing.

Thanks a _lot_ for answering. Here are the details:

Clients are NT 4.0 SP6 workstations, bound to an NT 4.0 Server PDC, both
German versions. Ordinary users do not have the rights to change the printer
driver defaults, so an admin has to do this.

The Samba-Server is 2.2.0 on Solaris 2.6. I also tried 2.2.0alpha3 on SuSE
Linux 7.0 with kernel 2.4.1 - same problem.
Printer driver were the original NT drivers (PostScript and PCL)
The steps were in detail:

- Start Samba-Server
- Log onto windows machine as user "root" (root is also in the local group
  of windows administrators)
- in Network-Neighbourhood open up Samba-Server, click on printers
(Printer name is displayed)
- right click on printer, click on properties
(NO DRIVER AVAILABLE is displayed)
- click on "New driver..."
- choose printer model (HP Laserjet 5M or HP Laserjet 5/5M PostScript)
- enter path to ppd-file (on Windows CD or anywhere)
- printer drivers are uploaded to the samba-server!
- click on "device settings"
- set page formats to A4, duplex unit installed etc.
- click "ok"
- again in explorer, right click on printer, click on "document defaults"
- change page size to "A4", duplex printing to "long edge"
- click ok
Now everything looks good.
- In Explorer/Printers Double Click on "add printer"
- choose "network printer"
- enter \\<<samba-host>\<printer-name>
- click "finish"
(Printer is installed then)
- Startup any Application that can print on a whole page (Internet Explorer,
  Word Pad, Netscape, etc.) The following example is for WordPad, but they
  behave all very similar.
- Click on "File/Page Setup"
- Be upset because of the page size being displayed as "Letter" or "A4 small"
  instead of "A4" which had been set before!
- Click on "Printer"
The Samba-Printer is displayed.
- Click on "Properties"
- The Page Size is "Letter" or "A4 small", not "A4"
Interesting thing: The setting for the duplexer is correct!
- Exit WordPad, delete Samba-Printer, reconnect to samba-printer with
  "Add printer", look at Document defaults: They are correct!
- Startup WordPad again: *sigh*

The ennoying thing is: If I do exactly the same thing with a driver which
is located on the NT server it all works. So I don't think it's an NT
_client_ related problem.

If I can make any other helpful tests or if you would like detailed logs
please tell me, I would be glad.



More information about the samba-technical mailing list