Weird smbsh and smbmount problem

Stepan, Jamison Jamison.Stepan at
Thu Nov 19 11:49:56 GMT 1998


I talked to John Terpstra and he said I should send this to the list. We
have a UNISYS Clearpath main frame that has some version of a SMB server to
allow for access from MS clients.
We recently tried upgrading to the 2.1.x kernel and because of that had to
switch to the new smbmount program. When we switched the performance to the
mainframe dropped through the floor. Plus we would get files that would seem
to disappear, or not show up through smbmount for hours. Through smbmount we
were able to get access to everthing else just fine, except the mainframe.
(I tried it with and without all the various bug fixes).
Well then John suggested I try smbsh. It also had the same speed problem to
the mainframe. Plus it also had a speed problem to samba shares. Anything
that was native NT worked great. Anything else was slow as molasses. Plus on
the mainframe we could not get into all the directories. The command 'ls
-al' or 'ls -F' simply hung.
That's about all I can think to report. If anyone needs me to try anything
let me know. Otherwise I hope this helps someone.


Jamison Stepan
Internet Application Developer
Minnesota Department of Children,
     Families and Learning
Jamison.Stepan at
jstepan at

More information about the samba-technical mailing list